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====== Création de Pantin (05/16) ====== --- //[[mathieu@les-fees-speciales.coop|Mathieu
Rubio]] 2016/05/25 13:00// \\ \\ ==== La préparation du pantin ==== {{:chrono.jpg?nolink&100|}}
Environ 15 min \\ \\ - Ouvrir sur Krita/Photoshop **le nouveau pantin** H09P (exemple) dans
''Dilili/LIB/Production/Modeles_Reception/<Date>_Livraison''.\\ \\ - **Le pantin ne doit pas regarder à
gauche**. Si c'est le cas, effectuer un miroir horizontal (Krita : Layer->Mirror Layer Horizontally). \\ \\ -
Ouvrir le **Gabarit** ''Dilili/LIB/Chars/Pantin/Tech/Gabarit'' et le glisser dans le layer du H09P (Image
B).\\ \\ - Réduire le pantin H09P (Krita : CTRL+T ), afin que la **ligne de repère soit IDENTIQUE** au
repère du Gabarit, puis rogner (CTRL+C)(Image C).\\ \\ - Une fois terminé, l'enregistrer avec la
**bonne nomenclature** dans ''Dilili/LIB/Production/Modeles_Reception_prepa_dispatch''.\\ \\ - Lancer
le script magique de Flavio, qui va s'occuper de créer des dossiers dans LIB et de créer une page sur
[[http://87.98.168.34:1901/|Criquet]].\\ \\ \\ \\ {{ :import_source_gabarit.jpeg?direct&450 |}} \\ \\ \\ \\
<WRAP center round help 60%> Si le pantin source n'a pas de ligne repère : - Importer **le nouveau
pantin**. \\ \\ - Ouvrir le jpg **Source_Repere** dans''/LIB/Chars/Pantin/Tech/'' et le glisser dans le
fichier du nouveau pantin. \\ \\ - Déplacer le nouveau pantin afin qu'il soit sur la même ligne de repère
que **Source_Repere**. \\ \\ - Copier la ligne repère et le fusionner au nouveau pantin. \\ \\ - Le
nouveau pantin possède donc la ligne repère, le tout dans un seul calque. \\ \\ - Puis reprendre l'étape
3. </WRAP> \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ ==== La fabrication du pantin==== {{:chrono.jpg?nolink&70|}}
Environ 3h-4h{{ :vrai_pantin.jpg?direct&70|}} \\ \\ Avant de commencer la fabrication, un vrai pantin
est disponible en papier-découpé dans le bureau. Il permet de bien comprendre comment on doit
placer les joints, et découper le dessin en fonction. {{ :nomenclature.png?nolink&300|}} - Ouvrir le
pantin dans ''Dilili/LIB/Chars/Pantin/<LeNomduPantin>/Fab''. \\ \\ - **Enregistrer** une v02 comme
ceci : ''LIB_Chars_Pantin_<LeNomduPantin>_fab_v02''. \\ \\ - Ouvrir un nouvelle fenêtre dans krita,
faire ''Window'' → ''New window''. \\ \\ - Importer le psd **Nomenclature**
''Dilili/LIB/Chars/Pantin/Tech/Nomenclature'' dans la nouvelle fenêtre puis le faire glisser dans le
pantin. \\ \\ - Avec le psd Nomenclature, (image ci-contre), il n'y a **plus besoin de créer** des layers
ou des groupes. Tout est déjà fait. \\ \\ Même s'ils ne sont pas sur l'image, il y a plusieurs groupes
identiques, comme ''Bras_haut_droit_GR'', ''Bras_haut_gauche_GR'', ou ''Bras_haut_GR''. \\ \\ Les
groupes et les layers sont vides, seules la nomenclature et la hiérarchie nous intéressent. \\ \\ Donc si
vous avez un **pantin avec un seul bras**, et qu'il ne faut pas créer un second bras, alors
**supprimer les groupes gauche et droite**. \\ \\ À l'inverse, si le **pantin a deux bras** bien distincts,
**supprimer le groupe bras**.\\ La même chose pour les jambes. \\ \\ \\ \\ <WRAP center round tip
60%> Quelques exemples : \\ \\
{{:nomanclature_explication.jpeg?direct&100|}}{{:supression_blanc.jpeg?direct&100|x}}{{:colorisa
tion.jpeg?direct&100|}}{{:colorisation_trait.jpeg?direct&135|}}{{:pantin_partis_du_corps.jpeg?direct
&75|}}{{:pantin_wiki.jpeg?direct&100|}} </WRAP> \\ \\ - {{ :gif_merge.gif?direct&170|}}Dupliquer
le ''joint modele'' et le placer à **l'articulation** du bras (par exemple).\\ Puis placer ce joint au
dessus de ''Joint_bras_haut'' et fusionner en faisant un ''clic droit'' → ''Merge below''. Cela permet de
respecter la nomenclature, sans avoir à nommer les layers. \\ Ne pas hésiter à tester le pantin qui se
trouve quelque part dans le bureau, et qui n'attend que d'être touché par vos petites mains :).\\ \\ -
Ensuite découper chaque partie autour des articulations dans les différents layers, en **fusionnant à
chaque fois le layer dans la bonne nomenclature.** \\ \\ \\ \\ <WRAP center round important 60%> {{
:pied.png?direct&200|}}Le **placement** et la **découpe** des pantins est **cruciale** pour le rig,
l'animation, et la qualité du pantin.\\ Il faut absolument prendre le temps d'essayer chaque
articulation.\\ \\ Car si on se rend compte qu'il y a un **problème** pendant le rig, alors on **perdra
beaucoup de temps** à revenir sur Krita, faire les modifications, et recommencer le rig. </WRAP> \\ \\
- Une fois les joints placés, et les articulations découpées, on peut passer à la colorisation. \\ \\ -
Quand la colo est finie, il est **IMPORTANT** de tester chaque articulation. Cela permettra de se
rendre compte une fois **le rig posé**, qu'une **articulation ne marche pas**. \\ \\ {{
:cacher_joints.jpeg?direct&80|}} - Après avoir testé le pantin, appeler Léo ou Mathieu afin qu'il valide
le pantin. \\ \\ - Bravo, la partie la plus longue est terminée, il ne reste plus qu'à enregistrer dans une
nouvelle version : **LIB_Chars_Pantin_<nom_pantin>_fab_REF**, en fusionnant les **joints** et en les



Last update: 2016/06/03 15:49 pantins_procedure https://les-fees-speciales.coop/wiki/pantins_procedure?rev=1464965345

https://les-fees-speciales.coop/wiki/ Printed on 2025/09/24 19:37

laissant **apparents**, ainsi que le layer paupière. Cacher les layers qui ne servent pas. \\ \\ \\ \\ \\ \\ \\
\\ \\ \\ ==== Le rig du pantin ==== {{:chrono.jpg?nolink&100|}}Environ 20 min \\ \\ - Ouvrir une
scène vierge dans Blender. \\ Selectionner la caméra, le cube, et la lampe et les supprimer avec la
touche ''X''. \\ Puis enregistrer cette scène vide dans ''/LIB/Chars/Pantin/<nom_pantin>/actor'' et la
nommer comme ceci : **LIB_Chars_Pantin_<nom_pantin>_actor_v01**.\\ \\ - Aller dans User
Preferences '' Ctrl Alt U '' ou File → User Preferences → Add-ons. \\ Vérifier avec l'aide de la loupe si, ''
Rigify '' est activé, ainsi que'' Import psd as planes '' puis '' Parent planes to bones''. \\ Afin d'éviter de
cocher à chaque nouveau rig, il est possible de sauvegarder ces préférences en cliquant en bas ''Save
User Settings''.\\ \\ \\ \\ <WRAP center round important 60%> {{ :cursortocenter.png?direct&100|}}\\
**Bien vérifier** que le curseur est positionné au **centre** de la scène. Sinon, faire ''SHIFT + C''
</WRAP> \\ \\ - Une fois que le curseur 3D {{:blender-3d-cursor.png?direct&50|}} est bien au centre,
ouvrir **la fenêtre search** avec la touche''Espace'' et écrire ''Import PSD as Planes'' (ou simplement
''psd''). \\ Puis importer **le psd REF** dans ''/LIB/Chars/Pantin/<nom_pantin>/fab''.\\ \\ \\ \\ <WRAP
center round important 60%>{{ :preset_import_pantin.png?direct&70|}} **Avant de valider**,
sélectionner le preset **Import pantin**. \\ Sinon les /personnages auront la taille de Godzilla. \\ Et
c'est pas cool. </WRAP> \\ \\ - Le pantin est apparu dans la scène. Mais il est tout gris pas vrai ? Pas
de panique. Il faut juste afficher les textures. \\ Pour ce faire suivre cette image ⇒
{{:texture.jpeg?direct&100|}}\\ \\ - Sélectionner tout le pantin, en appuyant sur la touche ''A''. \\ Puis
faire ''Alt P'', Clear and keep transformation.\\ \\ - Dans le but d'avoir une scène propre, sélectionner
les ''empties'' et les supprimer.\\ \\ - Sélectionner la plaque de joints, et la bouger dans l'axe Y afin
qu'elle soit devant le pantin. \\ \\ - Créer l'armature en **Object Mode** dans: **Add -> Armature ->
Pantin(Meta-Rig)**. \\ \\ - S'il y a besoin, sélectionner les plaques et les rapprocher du rig. En aucun
cas le rig ne doit se déplacer. \\ \\ - Pour plus de lisibilité, à droite cocher X-Ray et Wire ⇒
{{:xray.png?direct&50|}} \\ \\ - En ''Edit Mode'', sélectionner les bones et les placer chirurgicalement
au centre des joints(utiliser la touche ''SHIFT'' pour plus de précision). Le talon et la pointe du pied
doivent toujours être au sol.\\ \\ \\ \\ <WRAP center round important 60%> {{ :bon_ik.png?200|}}\\ \\
Pour que le l'IK **fonctionne**, il faut respecter les angles de rotation logiques. Exemple, sur l'image :
l'angle saillant (<180°) doit se situer derrière le genou. </WRAP> \\ \\ - Si le pantin possède 2 bras
et/ou 2 pieds, se mettre en ''Edit Mode'' et dupliquer (''Shit+D'') la chaîne de bones. \\ {{
:dupplicatelr.png?direct&70|}} Une fois la nouvelle chaîne de bones bien replacée, sélectionner en
''Pose Mode'' le premier bone de la chaîne (ex:bras_haut_gauche) et dans les propriétés du bone,
décocher tout en bas ''Duplicate LR'' et choisir ''Left''/''Right''.\\ **Faire la même chose pour l'autre
coté !!**\\ \\ \\ - Placer le bone des paupières approximativement comme sur l'image
:{{:bonepaupiere.png?direct&100|}} \\ \\ - {{ :generate.png?direct&60|}} Quand on a bien fait
toutes ces étapes, toujours en ''Pose Mode'', aller dans l'onglet Armature et cliquer sur ''Generate''. \\
\\ \\ \\ - Vérifier que le Rig fonctionne bien, si oui, passer à l'étape suivante ! \\ \\ \\ - Cacher le Meta-Rig
et les controleurs dont on ne se servira pas. \\ \\ \\ - {{ :parentplanes.png?direct&60|}} Sélectionner
le rig en ''Pose Mode'' et cliquer sur ''Parent Planes to Bones'' à gauche. S'il n'y est pas, ça signifie que
**l'étape 2** n'a pas été respectée. Aïe aïe aïe...\\ \\ \\ - {{ :wgt.png?direct&60|}}Supprimer les
widgets. Pour être rapide, taper dans l'Outliner ''WGT''. Toujours dans l'Outliner, appuyer sur ''A'' pour
tout sélectionner. Et désélectionner (''Ctrl''+''Maj''+''Clic gauche'') "''Scene''". Puis supprimer (''Clic
droit'' ->''Delete'') les widgets.\\ \\ \\ \\ \\ \\ - Ensuite il faut créer un groupe. Pour ce faire, sélectionner
le rig (rendre les objets sélectionnable), puis sélectionner ''Select Hierarchy''.\\ Puis ''Ctrl G'' → ''Assign
New Group'' et le nommer par le nom du pantin, dans l'option à gauche.\\ \\ - Nommer le 'rig' par le
nom du pantin.\\ \\ - Sélectionner le rig, en ''Object Mode'' puis aller dans **File** → **External Data**
→ cocher **Automatically packing to blend**\\ Ensuite File → External Data → **décocher**
Automatically packing to blend.\\ Enfin File → External Data → **Unpack all into file** → **Write files to
current directory**. \\ \\ - Une fois qu'on est sûr à **200%** que le rig fonctionne **parfaitement**,
enregistrer dans une nouvelle version, **LIB_Chars_Pantin_<nom_pantin>_actor_REF** . \\ \\
Félicitations, on a maintenant un super pantin qui va pouvoir danser la samba =) \\ \\ \\ \\ \\ \\ \\ \\ \\ \\
==== L'animation du pantin ==== - En partant du fichier de rig (''actor''), on enregistre sous dans
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''/LIB/Chars/Pantin/<pantin>/animation/<pantin_animation_v01.blend>''. \\ \\ - Faire une super
animation. Cette animation pourra être importée plus tard sous la forme d'''action''.\\ \\ - Une fois
l'animation fini, dans l'outliner →''animation'' → puis renommer ''<nom_pantin>Action_<nom_anim>''.
\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ ==== L'importation de l'animation ==== - Dans la **scène de destination**
faire un link/append de l'''actor''. \\ \\ * S'il s'agit d'un rig généré avec le ''Pantin'' de Rigify (autorig) : *
Il faut importer un script généré par l'autorig pour obtenir toutes les fonctionnalités du pantin : * Faire
un link du texte ''rig_ui.py'' depuis le fichier actor, le cas échéant * Ouvrir ce texte dans une fenêtre
d'éditeur de texte * Lancer le script (en bas, ''Run Script'') et cocher ''Register'' pour que le script soit
lancé à chaque fois que la scène est ouverte * Faire un link de l'anim * Sélectionner l'actor importé
(instance de groupe), et faire ''CTRL + ALT + P'' (Make Proxy). Choisir le rig dans le menu qui
s'affiche. * Sélectionner le proxy (version locale) du rig, puis : * Aller dans la vue NLA (Non Linear
Editor) * Si le fichier n'a pas d'action, créer une clef (insert keyframe) sur n'importe quoi (par exemple
la location) * Sélectionner l'action du rig, ouvrir le panneau N * Ouvrir Animation Data * Remplacer
l'action par celle que l'on a linkée
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